Internet Explorer versions 6, 7, and 8 are not officially supported by Kiln. This means you may see errors if you access Kiln from these browsers. While we do our best to make Kiln work in every browser, these versions of Internet Explorer are by now quite outdated, and have bugs, flaws, security problems, and missing features that cause Kiln to work poorly.

Additionally, older versions of other browsers (such as Firefox 3.6 and earlier and Safari 3 and earlier) are not supported. Again, you may see bugs or errors.

Our engineering resources are better spent creating awesome new features than in chasing bugs caused by old browsers.

Fog Creek recommends using a new version of one of the following browsers, which can be installed easily and quickly on your PC:

If you’re unable to upgrade or change your browser, please get in touch and we’ll try to help you out.